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Цель работы: Ознакомить студентов с основными теорети-

ческими понятиями нечеткой логики и получить практические 

навыки по решению задач нечеткой логики с использование ма-

тематического пакета MatLab. 

ОСНОВНЫЕ ТЕОРЕТИЧЕСКИЕ ПОЛОЖЕНИЯ 

 

Нечеткая логика – это обобщение традиционной Аристоте-

левой логики на случай, когда истинность рассматривается как 

лингвистическая переменная, принимающая значения типа: 

"очень истинно", "более-менее истинно", "не очень ложно" и т.п. 

Указанные лингвистические значения представляются нечеткими 

множествами. 

Лингвистической называется переменная, принимающая 

значения из множества слов или словосочетаний некоторого 

естественного или искусственного языка. Множество допусти-

мых значений лингвистической переменной называется терм-

множеством. Задание значения переменной словами, без исполь-

зования чисел, для человека более естественно. Ежедневно мы 

принимаем решения на основе лингвистической информации ти-

па: "очень высокая температура"; "длительная поездка"; "быст-

рый ответ"; "красивый букет"; "гармоничный вкус" и т.п. Психо-

логи установили, что в человеческом мозге почти вся числовая 

информация вербально перекодируется и хранится в виде линг-

вистических термов. Понятие лингвистической переменной игра-

ет важную роль в нечетком логическом выводе и в принятии ре-

шений на основе приближенных рассуждений. Формально, линг-

вистическая переменная определяется следующим образом. 

Лингвистическая переменная задается пятеркой , 

где   – имя переменной;   – терм-множество, каждый элемент 

которого (терм) представляется как нечеткое множество на уни-



3 

 

версальном множестве ;   – синтаксические правила, часто в 

виде грамматики, порождающие название термов;   – семанти-

ческие правила, задающие функции принадлежности нечетких 

термов, порожденных синтаксическими правилами . 

Нечеткая логика с использованием пакета MatLab 

В любом математическом пакете среднего и высокого уров-

ня предусмотрен такой пакет, который позволит решать задачи с 

использованием нечетких выражений, а именно нечеткая логика. 

Мы же разберем использование системы MatLab для решения за-

дач с использованием нечетких множеств.  

Для включения пакета используется команда «fuzzy», что с 

английского языка переводится как «нечеткий», после введения 

данной команды откроется окно, которое и представляет собой 

меню, которое используется для решения нечетких выражений. 

 

Рисунок 1 Основное окно пакета 

Окно данного пакета содержит следующие элементы:  

 File – основные функции позволяющие: 
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 New FIS – создание нового файла; 

 Import – позволяет сохранять файл; 

 Export – Открыть сохраненный файл; 

 Print – Печать; 

 Clouse – Закрыть. 

 Edit – функции позволяющие работу непосредственно с 

данным файлом: 

 Add Variable – Добавление входа или выхода; 

 Remove selected variable – позволяет удалить какую ли-

бо переменную; 

 Membership Function – позволяет описывать функции 

принадлежности; 

 Rules – позволяет формулировать логические правила. 

 View – позволяет визуализировать результаты в виде 

графиков 

Если нажимаем на вход или выход появляется еще одно ок-

но позволяющее работать непосредственно с графиками принад-

лежности и установлением параметров для работы с данными: 

 

Рисунок 2 Основные функции работы с параметрами 

Имя входа 

(выхода) 

Тип объекта 

 

Диапазон 

Дисплей 

индикации 

Графики 

 

Имя графика 

 

Тип графика 

 

Парамет-

рыграфика 
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Если зайти в раздел «Правила» то откроется следующее ок-

но, в котором формулируются правила взаимосвязи «входов» с 

«выходом». 

 

Рисунок 3 Раздел формулирования правил 

ПРИМЕР ВЫПОЛНЕНИЯ РАБОТЫ 

Условие задачи:  

Рассмотрим ситуацию в ресторане, при которой, согласно 

принятым традициям, после окончания обслуживания посетителя 

принято оставлять официанту чаевые. Основываясь на устояв-

шихся обычаях и интуитивных представлениях посетителей ре-

сторанов, величина суммы чаевых не является постоянной и за-

висит, например, от качества обслуживания и качества приготов-

ления заказанных блюд. 

Задача состоит в том, чтобы разработать некоторую экс-

пертную систему, которая была бы реализована в виде системы 

Окно правил 

 

Выбор входа 

 

Отрицание 

 

Логические 

условия 

 

Вес функции 

 

Удалить пра-

вило 

Добавить 

правило 

Изменить 

правило 
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нечеткого вывода и позволяла бы определять величину чаевых на 

основе субъективных оценок посетителей качества обслуживания 

и качества приготовления заказанных блюд.  

1. Определимся с входными и выходными лингвистиче-

скими параметрами. 

Входными параметрами будут: Качество ужина и качество 

обслуживания. 

Выходным параметром будет: Размер чаевых. 

2. Зададим терм-множества лингвистических перемен-

ных: 

 «Качество обслуживания»     («хорошее», «среднее», 

«отлично»); 

 «Качество ужина»     («подгоревший», «превосход-

ный»); 

 «Величина чаевых»   («малые», «средние», «высо-

кие»); 

При этом каждый из термов будет оцениваться по 10 баль-

ной шкале, т.е. 0 – низшая оценка, а 10 – наивысшая. 

Для термов выходной переменной предположим: 

 Малые 5% ≈ чаевые; 

 Средние 15% ≈ чаевые; 

 Щедрые примерно 25% ≈ чаевые от стоимости блюд. 

Теперь субъективная информация о величине чаевых может 

быть представлена в форме 3-х правил: 

 Правило 1: ЕСЛИ "качество обслуживания плохое" 

ИЛИ "ужин подгоревший "ТО "величина чаевых малая"; 

 Правило 2: ЕСЛИ "качество обслуживания хорошее" 

ТО "величина чаевых средняя"; 
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 Правило 3: ЕСЛИ "качество обслуживания отличное" 

ИЛИ "ужин превосходный" ТО "величина чаевых щедрая". 

3. Теперь приступаем к разработке системы нечеткого 

вывода в интерактивном режиме. 

Процесс разработки сводиться к выполнению следующей 

последовательности действий: 

1. Вызвать редактор систем нечеткого вывода FIS, для че-

го в окне команд набрать имя соответствующей функции fuzzy. 

2.  EditДобавим в разрабатываемую систему FIS еще 

одну входную переменную >Add Variable... >Input. 

3. Изменим имена входных и выходных переменных, 

предложенных системой MATLAB. Выделим прямоугольник с 

именем соответствующей переменной. Затем введём новое имя 

переменной в поле ввода Name в правой части редактора FIS. 

 

Рисунок 1 Окно редактора FIS Editor 
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1.  FileИзменим имя системы нечеткого вывода 

(Untitled). Для этого сохраним создаваемую структуру FIS во 

внешнем файле с именем mytip.fis, >Export>ToDisk…. Никакие 

параметры кроме имени файла изменять не следует. 

2. Теперь необходимо определить термы и их функции 

принадлежности для входных и выходных переменных нашей си-

стемы нечеткого вывода. Для этой цели следует воспользоваться 

редактором функций принадлежности, который может быть вы-

зван одним из следующих способов: 

o двойным щелчком на значке прямоугольника с именем 

соответствующей переменной; 

o командой меню Edit>Membership Functions... 

o нажатием клавиш <Ctrl>+<2> 

После вызова редактора функций принадлежности каждой 

из переменных по умолчанию предлагается 3 терма с треуголь-

ными функции принадлежности. 

Вначале изменим диапазон определения значений входных 

переменных, для чего в полях ввода Range и Display Range изме-

ним верхнее значение с 1 на 10 (баллов). Аналогично выполня-

ются изменения соответствующих диапазонов для выходной пе-

ременной "чаевые", при этом верхнее значение 1 следует заме-

нить на 30 (%). Изменения подтверждаются нажатием на клави-

шу <Enter> на клавиатуре. 

Далее изменим названия термов первой входной перемен-

ной "обслуживание", на "плохое", "хорошее", "отличное" соот-

ветственно. После чего изменим тип функций принадлежности 

первой переменной, предложенный по умолчанию, на функции 

типа Гаусса (gaussmf), выбрав соответствующий пункт в поле 

Туре. Параметры вновь заданных функций принадлежности оста-

вим без изменения. 
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Рисунок 2 Функции принадлежности входной переменной  

«Обслуживание» 

Аналогичным образом изменим названия термов второй 

входной переменной "ужин" и удалим один из термов с соответ-

ствующей функцией принадлежности. Для удаления терма следу-

ет выделить удаляемую функцию принадлежности и нажать кла-

вишу <Delete> на клавиатуре. Переход к редактированию пере-

менной осуществляется щелчком на изображении прямоугольни-

ка с именем необходимой переменной. Для переменной "ужин" 

изменим тип функций принадлежности ее термов на трапецие-

видные функции (trapmf) и их параметры следующим образом: 

для терма "подгоревший" зададим параметры [0 0 1 3], а для тер-

ма "превосходный" – [7 9 10 10]. 
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Рисунок 3 Функции принадлежности выходной переменной 

«Ужин» 

Наконец, изменим названия термов и параметры функций 

принадлежности для выходной переменной "чаевые", оставив без 

изменения треугольный тип функций принадлежности, предло-

женный системой MATLAB. Для терма "малые" зададим пара-

метры [0 5 10], а для терма "средние" – [10 15 20], для терма 

"щедрые" – [20 25 30]. 
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Рисунок 4 Функции принадлежности выходной переменной 

«Чаевые» 

1. Определим правила нечеткого вывода для разрабаты-

ваемой экспертной системы. Для этой цели следует воспользо-

ваться редактором правил, который может быть вызван одним из 

следующих способов: 

o двойным щелчком на значке квадрата в центре с име-

нем создаваемой системы нечеткого вывода (myfis); 

o командой меню Edit>Rules...; 

o нажатием клавиш <Ctrl>+<3>. 

Здесь зададим необходимые нам три правила определённые 

ранее. 
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Рисунок 5 База знаний в RuleEditor 

7. После задания правил нечеткого вывода оказывается 

возможным получить результат нечеткого вывода (значение вы-

ходной переменной) для конкретных значений входных перемен-

ных. С этой целью необходимо открыть программу просмотра 

правил одним из следующих способов: 

o командой меню View>Rules редактора FIS; 

o командой меню View>Rules редактора функций при-

надлежности; 

o командой меню View>Rules редактора правил; 

o нажатием клавиш <Ctrl>+<5>. 
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Рисунок 6 Визуализация нечеткого логического вывода в 

RuleViewer 

Изменим значения входных переменных для случая, кото-

рому соответствует качество обслуживания в 0 баллов ("хуже не-

куда") и качество ужина в 10 баллов ("лучше не бывает"). Для 

этого курсор мыши переместим в поле ввода Input и введем соот-

ветствующие значения входных переменных: со средних значе-

ний  [5 5] на [0 10]. Система MATLAB оставит значение чаевых 

без изменения (15%), однако на диаграмме правил можно заме-

тить результаты выполненных изменений. 
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Рисунок 7 Визуализация нечеткого логического вывода 

в RuleViewer при входных значениях 1 и 10 

Теперь предположим, что качество обслуживания оценива-

ется в 10 баллов ("лучше не бывает"), а качество ужина — в 

2 балла ("бывает и хуже, но реже"). Введем соответствующие 

значения переменных аналогичным способом. В этом случае раз-

работанная система нечеткого вывода рекомендует нам оставить 

чаевые в размере 16.4%. 

Если же предположить, что качество обслуживания по 

прежнему отличное (10 баллов), а качество ужина несколько 

улучшилось и оценивается в 8 баллов, то величина чаевых суще-

ственно изменится и станет равной 24.7%. 
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Рисунок 8 Визуализация нечеткого логического вывода 

в RuleViewer при входных значениях 10 и 8 

Более того, дальнейшее увеличение качества ужина не ока-

зывает изменения величины чаевых. В частности, для значений 

входных переменных [10 10] величина чаевых составит по-

прежнему 24.7%. 

8. Для окончательного анализа разработанной нечеткой 

модели может оказаться полезной программа просмотра поверх-

ности нечеткого вывода, которая может быть вызвана одним из 

следующих способов: 

 командой меню View>Surface редактора FIS; 

 командой меню View>Surface редактора функций при-

надлежности; 

 командой меню View>Surface редактора правил; 

 командой меню View>Surface программы просмотра 

правил; 

 нажатием клавиш <Ctrl>+<6>. 
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Рисунок 9 Поверхность “входы-выход” в окне SurfaceViwer [2] 

ЗАДАЧИ ДЛЯ ЛАБОРАТОРНОЙ РАБОТЫ 

 

1. Создайте экспертную систему, на основе нечеткой ло-

гики, позволяющей определить вероятность появления ДТП, в 

зависимости от возраста водителя и состояния машины. 

2. Создайте экспертную систему, на основе нечеткой ло-

гики, позволяющей определить значение температуры, в зависи-

мости от давления и влажности. 

3. Создайте экспертную систему, на основе нечеткой ло-

гики, позволяющей определить быстроту доставки товара, в зави-

симости от состояния дороги, состояния шин автомобиля и опыта 

вождения водителя. 
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ТРЕБОВАНИЯ К ОТЧЕТУ 

 

1. Исходные данные; 

2. Пошаговое выполнение всех действий; 

3. Описание всех правил и графиков; 

4. Выводы. 

КОНТРОЛЬНЫЕ ВОПРОСЫ 

 

1. Назначение нечеткой логики?  

2. В чем отличие нечеткой от традиционной логики? 

3. Лингвистическая переменная, для чего она использует-

ся и что содержит? 

4. Назначение команды «fuzzy». 

5. Как формулируются правила в MatLab? 

СПИСОК ИСПОЛЬЗУЕМОЙ ЛИТЕРАТУРЫ 

 

1. Электронный ресурс: 

http://matlab.exponenta.ru/fuzzylogic/book1/1_7.php;[1] 

2. Электронный ресурс: 

http://www.studfiles.ru/preview/2704321/ [2] 

 

http://matlab.exponenta.ru/fuzzylogic/book1/1_7.php
http://www.studfiles.ru/preview/2704321/

